2011 Dodge Charger defects battery drain dead.


2011 Dodge Charger defects battery drain dead.

2 days in a row I’ve had to get my 2011 Dodge Charger jumped because the battery died from being drained. My car only has 900 miles on it and I’ve owned it for 4 months. After checking Charger forums.com I saw that a lot of people are having the same issue.

Top 5 Muscle Car Searches:

2011 dodge charger battery drain -
Tags: , , , , , ,
Posted in Muscle Car Videos on Dec 8th, 2011, 12:23 am by Next Generation Muscle Cars

25 Responses for 2011 Dodge Charger defects battery drain dead.

  1. vkeagle1
    December 8th, 2011 | 12:59 am

    Ironic, We bought our 2011 Charger R/T July, battery went dead one occassion, Uconnect having problems synching, and just yesterday brake, ABS, and traction control lights on dash came on and run light on ignition button was on however car would not start!! Love the design of car but it is appearing to be a LEMON New Car. very pissed!! Been to dealership on 9 occassions in 4 months, WTF

  2. DaddyIvo
    December 8th, 2011 | 1:19 am

    That’s not cool at all! I love the design of the Charger and 300c! Chrysler Corp. should’ve corrected that issue right off the assembly-line! What if you were taking a road-trip thinking “I gotta’ brand new whip and it’s all-good”? Hope it’s been resolved. Still a sweet-looking ride!

  3. 88888888888anonymous
    December 8th, 2011 | 1:47 am

    difference between dodge and chevy: my engine has 370 horse power. my CAR has 300. chevy runs deep

  4. KTHOMASG1
    December 8th, 2011 | 2:22 am

    Its that push to start that was affecting my car. I have a 2010 Nissan Altima and i had my car jumped after a month of owning it. I really hate it. And when the car battery dies i cant get into my car at all. So be lucky you can even do that.

  5. Decypher85350
    December 8th, 2011 | 2:27 am

    ive had mine since February and this hasnt happened,, it has 12,000 miles already lol
    do you have any problems with the tire rubbing or anything?

  6. GoCubsSoxSuck123
    December 8th, 2011 | 3:09 am

    @savagelife005busa its minor stuff. buy one and you’ll fall in love with it.

  7. GoCubsSoxSuck123
    December 8th, 2011 | 3:13 am

    I feel your problem bro. I had to change the handles 3 times, repaint the bumper, dealer wrecked interior parts and had a blackberry blue handle installed instead of the black. Hope everything is going smoothly

  8. carmeusjacob
    December 8th, 2011 | 3:41 am

    wow I thought I was the only one with a 2011 lemon. I bought mine in february and had the whole front dash cam shaft sensor and o2 sensor changed already. keyless entry stopped the first time I washed it.

  9. TexasTough
    December 8th, 2011 | 4:25 am

    @caesarsteels thanks for the heads up. It actually came on 2 weeks ago (service key system notice), but has since gone away. but today my keyless entry stopped working on the driver side. whatever the case I will have it checked out. No worries im still under warranty, but its a shame that these amazing rides are defective.

  10. caesarsteels
    December 8th, 2011 | 4:54 am

    @TexasTough the auto door handles on these are defective, so if ur service key notice comes on then u need to get that fixed ASAP or ur battery will drain

  11. TexasTough
    December 8th, 2011 | 5:21 am

    man wtf! this shit better not happen to mine, i’d be so fkn pissed.

  12. zerogwilmer
    December 8th, 2011 | 6:03 am

    I woke up this morning to take my daughter to school.. car wouldn’t start..battery is completely dead. and it’s her first day of school. pretty pissed off.

  13. TheDarthEmperor
    December 8th, 2011 | 6:51 am

    I had the sam problem. Took it to the dealer and there was a recall for a software update, and that did the trick.

  14. mrsd6allnatural
    December 8th, 2011 | 6:58 am

    Thanks for posting. I had a similar situation happen to mine on 8/13. Tripped me out. The dash was in German and the power was sluggish. We jumped it off and after letting it run for a while it slowly got better. Two days later the Uconnect started acting up. My phone dropped off and it would not reconnect. The dealer checked the battery and said it was good.It has been pretty ok since but now I think I will follow your lead and have them check out the Uconnect.

  15. jjchargerboy16
    December 8th, 2011 | 7:03 am

    I’m still getting one.

  16. jjchargerboy16
    December 8th, 2011 | 7:47 am

    @SuperTriniking yeah, its the Uconnect Module that is draining the battery. Your going to have to wait for a month to hear the results, as his new part is on back order.

  17. savagelife005busa
    December 8th, 2011 | 8:42 am

    Damn makin me have 2nd thoughts

  18. mpc4000king
    December 8th, 2011 | 9:15 am

    I have had the exact same problems. It’s the door handles!

  19. SuperTriniking
    December 8th, 2011 | 9:16 am

    @caesarsteels HI, this just happened to me 2 days ago, I have the same exact R/T max model as you. DID the dealer find out exactly what was the problem and did it happen again? Please let me know. Thank you

  20. cbrighten1
    December 8th, 2011 | 9:55 am

    This just happened to me after having my new 2011 charger r/t for 21/2 weeks!! Ughh can describe the level of pissed off I was they claim its an electrical problem w the the new models my service department sucked!! Makes me wish I never got a Dodge!!

  21. Defenstrator
    December 8th, 2011 | 10:52 am

    That sucks man. I can only hope I dodge that bullet.

  22. caesarsteels
    December 8th, 2011 | 10:55 am

    @Aaron77wil No, your wrong. I took it to the dealership, and there is a problem with the Uconnect module. thats what drained the battery and the part is on back order so i have no uconnect for about a month

  23. Aaron77wil
    December 8th, 2011 | 11:14 am

    that’s not a defect thats someone leaving something on all night and draining the battery………………

  24. perris1512
    December 8th, 2011 | 11:30 am

    that shit sux.. post up the 411 that the give you
    i took mine in for oli change service and they did a battery check thing failed.. but it hasnt died on me yet

  25. immuneshade
    December 8th, 2011 | 12:23 pm

    find out what was causing it?

Leave a reply for : 2011 Dodge Charger defects battery drain dead.